Search found 11 matches

by jinx182
Mon Dec 04, 2017 10:41 am
Forum: Lighting & Electronics
Topic: Using Aviation Power Connector
Replies: 2
Views: 213

Re: Using Aviation Power Connector

Thanks for the response. I'll give it a try.
by jinx182
Sun Dec 03, 2017 8:32 pm
Forum: Lighting & Electronics
Topic: Using Aviation Power Connector
Replies: 2
Views: 213

Using Aviation Power Connector

I've seen trek models using 4 pin aviation power connectors to mount onto a rod and base. I was wondering are there any tutorials out there that showed how to do this or at least a place to buy the pieces instead of buying the pre-assembled connector and rod I saw online.
by jinx182
Tue May 13, 2014 7:38 pm
Forum: Lighting & Electronics
Topic: LED Flicker Issue
Replies: 6
Views: 3315

I think you're right brt, I hooked the nacelles to a 19v power supply and there wasnt any issue. Thanks for the assist.
by jinx182
Tue May 13, 2014 12:01 pm
Forum: Lighting & Electronics
Topic: LED Flicker Issue
Replies: 6
Views: 3315

Thanks for the response. I'm not sure of the current but I'll check that out as soon as I get home tonight.
by jinx182
Mon May 12, 2014 9:24 pm
Forum: Lighting & Electronics
Topic: LED Flicker Issue
Replies: 6
Views: 3315

LED Flicker Issue

Hello all, I'm a really inexperienced when it comes to lighting model kits and electrical in general. I'll try to explain my problem as best I can. I am trying to light the nacelles on the Revell Into Darkness Enterprise. Inside each Nacelle I have Two 12v Led strips about 10 inches running along ei...
by jinx182
Tue Oct 26, 2010 8:42 am
Forum: Finishing
Topic: Cracks in my paint!
Replies: 10
Views: 3044

I read that last night on another thread. Live and learn I guess.
by jinx182
Mon Oct 25, 2010 7:58 pm
Forum: Finishing
Topic: Cracks in my paint!
Replies: 10
Views: 3044

I give up. I just laid my parts in a pine-sol bath. I'll try again in a few days With a different primer.
by jinx182
Mon Oct 25, 2010 5:45 pm
Forum: Finishing
Topic: Cracks in my paint!
Replies: 10
Views: 3044

I let the primer dry for four days but it did rain earlier today here so maybe that's it.
by jinx182
Mon Oct 25, 2010 4:20 pm
Forum: Finishing
Topic: Cracks in my paint!
Replies: 10
Views: 3044

Yeah, I think I am spraying the mtealizer on a little thick. I have to barely touch the model with a mist. If a spot starts look wet, the paint starts to crack.
by jinx182
Mon Oct 25, 2010 2:27 pm
Forum: Finishing
Topic: Cracks in my paint!
Replies: 10
Views: 3044

Cracks in my paint!

Hello everyone I have a little problem and i wanted to get some opinions on what i'm doing wrong. I'm building the PL 1/350 nx-01. After primig the model i used a can of model master metalizer (stainless steel). When the paint started to dry little areas with cracks in the paint started to on the su...
by jinx182
Sun Jun 08, 2008 8:05 pm
Forum: Lighting & Electronics
Topic: Lighting the defiant
Replies: 2
Views: 1301

Lighting the defiant

I was on the culttvman's website and I saw a guy lighting the defiant with fluorecent tubes. does anyone know how that is done and is it easy.